p5-Sub-Exporter-Progressive-0.001013nb1

Basic Info:

Only use Sub::Exporter if you need it

homepage: http://search.cpan.org/dist/Sub-Exporter-Progressive/
license: gnu-gpl-v2 OR artistic
install size: 9204
build date: 2017-11-09 21:58:09 +0000
package file: p5-Sub-Exporter-Progressive-0.001013nb1.tgz
package size: 7455

Description:

Sub::Exporter is an incredibly powerful module, but with that power comes
great responsibility, er- as well as some runtime penalties. This module
is a Sub::Exporter wrapper that will let your users just use Exporter if
all they are doing is picking exports, but use Sub::Exporter if your users
try to use Sub::Exporter's more advanced features features, like renaming
exports, if they try to use them.

Note that this module will export @EXPORT and @EXPORT_OK package variables
for Exporter to work. Additionally, if your package uses advanced Sub::Exporter
features like currying, this module will only ever use Sub::Exporter, so
you might as well use it directly.

Homepage:
http://search.cpan.org/dist/Sub-Exporter-Progressive/

Provides:

Requires:

Depends:

p5-Sub-Exporter-[0-9]*
perl>=5.26.0<5.28.0

Package List

File NameDateSize
lib/perl5/vendor_perl/5.26.0/Sub/Exporter/Progressive.pm2016-10-21 09:484812 bytes
lib/perl5/vendor_perl/5.26.0/x86_64-linux-thread-multi/auto/Sub/Exporter/Progressive/.packlist2017-11-09 14:58129 bytes
lib/perl5/vendor_perl/man/man3/Sub::Exporter::Progressive.32017-11-09 14:584263 bytes